[Madlug] Custom Linux Distro

Andrey Gordon homa2001 at inbox.ru
Thu Sep 1 14:45:58 CDT 2005


Is it possible to make a distro? not the installed system using this?
Basically, it is great, and I am definitely gonna put my time in it. But
it's not the only PC with the same driver that I need to put the system
on. From reading the  first chapter it sound to me that the result will
be is already installed system, right?

Thanks,
Andrey 

On Wed, 2005-08-31 at 22:48 -0500, Orien Colmer wrote:
> Sounds like you could use "Linux From Scratch" or LFS. I would
> recommend it to anyone. Check it out at:
> 
> http://www.linuxfromscratch.org/
> 
> This is a fantastic learning tool. It's also great for creating very
> light weight systems, or insanely customized systems. I highly
> recommend it. Basically, LFS is not software, it's a book that walks
> you through, step by step, to building your own system from scratch.
> And I mean REALLY from scratch! Gentoo eat your heart out.
> 
> I have a brother-in-law who is on a quest to use LSF and cross-compile
> techniques to get a 2.6 kernel on a m68k box (an old Mac SE30). He has
> Debian m68k on it now, but it has an old kernel and as far as we know
> there hasn't been anyone able to get an 2.6 kernel running on one yet
> :)
> 
> You gotta love Linux!
> 
> --Orien
> 
> On 8/31/05, Andrey Gordon <homa2001 at inbox.ru> wrote:
> > Can anyone direct me to how to create a custom linux distro?
> > 
> > Well, in particular I have spent about a week already messing with Dell
> > (Adaptec) SATA RAID array drivers. I have the drivers and when I do
> > "linux dd" and it prompt for the drivers everything goes fine. Linx RH9
> > is getting installed. But after reboot kernel panics and if I got to the
> > rescue mode it does not see the drives. Before kernel panics I can see
> > that bunch of functions and variables go undeclared and than insmod
> > "quits abnormally". I have tried to simply alternate initrd.img
> > drvblock.img on the RH9 install cd and after that it does not see the
> > cdrom as a install media like there is no install files.
> > I tried to ungzip initrd.img, mount it, ungzip and uncpio the
> > modules.cgz file that alternate the driver, that do reverse process
> > cpio,gzip,umount,gzip and did the same for drvblock.img (except it is
> > not gzipped) and got the same type of error when it does not see to
> > media. I think maybe there is a checksum or something stored on CD so it
> > does not match.
> > 
> > Any thought?
> > 
> > PS RHE3 installes just fine and the modification date on the files is
> > only a half year younger.
> > 
> > Thanks,
> > Andrey
> > 
> > --
> > Andrey Gordon <homa2001 at inbox.ru>
> > 
> > _______________________________________________
> > Madlug mailing list  -  Madlug at madisonlinux.org
> > http://www.madisonlinux.org/mailman/listinfo/madlug
> >
> 
-- 
Andrey Gordon <homa2001 at inbox.ru>




More information about the Madlug mailing list