[Madlug] just call me Colonel Panic!

Brian Hagen bdhagen at jvlnet.com
Tue Dec 7 14:47:37 CST 2010


    After a protracted time of experimenting I finally got Linux-wireless
working on a laptop. It was with Debian 5.04 and ran like a champ. Now I
installed Ubuntu 10.10-desktop to another partition and am regretting 
the decision.
This is because the installation  procedure apparently "commandeered the 
boot-loader"
to the effect that the Debian OS is no longer available!

    The Debian system is in fact still there on /devsda2 and presumably 
intact.
I just cannot get it to be included in the startup boot-loader display. 
So far I have installed
various versions of Ubuntu trying to get them to recognize the Debian 
system. The install
states that it "sees" the Debian system, but the resulting "grub.cfg" 
does not list it at all.
Trying to "force the matter" by editing grub.cfg has not been successful.

    I have tried to re-install the Debian system. During the initial 
install ("way back when)",
it stopped at a prompt which informed me that a "non-free firmware file" 
named "ipw2100-1.3.fw"
was needed for the wireless card. The first time around I downloaded it 
from a separate
source and placed it onto a USB drive. That worked fine. Now it does not 
see the file
on the USB stick. Bootups from another OS on the same laptop verify that the
file is still there and in fact, a "diff" command from the Debian OS 
partition and the USB
copy confirms that the file is the same. Even so, the install cannot 
locate it, and
hence the wireless firmware does not get installed. The install CD with 
the wireless
card (external) has the card's drivers, but not the firmware for it.

    What I want to do is regain control of the boot-loader so that it 
acknowledges the
Debian OS again and presents it as a valid option for multi-OS bootup ...

Brian H.


More information about the Madlug mailing list